LightOJ - 1148思维模拟

Mob was hijacked by the mayor of the Town "TruthTown". Mayor wants Mob to count the total population of the town. Now the naive approach to this problem will be counting people one by one. But as we all know Mob is a bit lazy, so he is finding some other approach so that the time will be minimized. Suddenly he found a poll result of that town where Npeople were asked "How many people in this town other than yourself support the same team as you in the FIFA world CUP 2010?" Now Mob wants to know if he can find the minimum possible population of the town from this statistics. Note that no people were asked the question more than once.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with an integer N (1 ≤ N ≤ 50). The next line will contain N integers denoting the replies (0 to 106) of the people.

Output

For each case, print the case number and the minimum possible population of the town.

Sample Input

2

4

1 1 2 2

1

0

Sample Output

Case 1: 5

Case 2: 1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxn 105
#define maxm 1000005
using namespace std;
int a[maxn];
int ans[maxm];
int mark[maxm];
int vis[maxm];
int t;
int main()
{
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
        int n;
        scanf("%d",&n);
        memset(vis,0,sizeof(vis));
        memset(mark,0,sizeof(mark));
        int cnt=0;
        for(int i=1;i<=n;i++)
            {scanf("%d",&a[i]);
            if(!vis[a[i]+1])
            {
                ans[cnt++]=a[i]+1;
                vis[a[i]+1]=1;
            }
            mark[a[i]+1]++;

            }

            int sum=0;
            for(int i=0;i<cnt;i++)
                sum+=ceil(mark[ans[i]]*1.0/ans[i])*ans[i];

      printf("Case %d: %d\n",w,sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/88747661
今日推荐