1083:蓝桥杯 Hello word! c++

题目描述

This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

输入

The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

输出

Output the corresponding message. Note there is NOT a newline character in the end of output.

样例输入

72 101 108 108 111 44
32 119 111 114 108 100 33

样例输出

Hello, world!

代码:

首先正确的:

#include <iostream>

using namespace std;
int main() {
    int t1;

    while (cin>>t1) {
        cout << char(t1);
    }

    return 0;
}

另一个把cin放到while判断语句的外面,会有输出超限的问题:

#include <iostream>

using namespace std;
int main() {
    int t1;
    cin>>t1;

    while (char(t1)!=EOF) {
        cout << char(t1);
        cin>>t1;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42082542/article/details/86756371