Linux yun命令使用报错:File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:

原文参考:https://www.cnblogs.com/caiji/p/7891923.html

 

使用yum更新perl源,报错

 

问题出现原因: 
yum包管理是使用python2.x写的,将python2.x升级到python3.x以后,由于python版本语法兼容性导致问题出现 
解决办法: 
修改yum配置文件,将python版本指向以前的旧版本

# vi /usr/bin/yum
#!/usr/bin/python2.7

修改urlgrabber-ext-down文件,更改python版本

# vi /usr/libexec/urlgrabber-ext-down
#!/usr/bin/python2.7
 

问题出现原因: 
yum包管理是使用python2.x写的,将python2.x升级到python3.x以后,由于python版本语法兼容性导致问题出现 
解决办法: 
修改yum配置文件,将python版本指向以前的旧版本

# vi /usr/bin/yum
#!/usr/bin/python2.7

修改urlgrabber-ext-down文件,更改python版本

# vi /usr/libexec/urlgrabber-ext-down
#!/usr/bin/python2.7

猜你喜欢

转载自www.cnblogs.com/zlf1/p/10373428.html
0条评论
添加一条新回复