多校赛第七场

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/readlnh/article/details/52176065

hdu5810

Problem Description

Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After the experiment, he calculated the statistical variance V as
V=∑mi=1(Xi−X¯)2m
where Xi is the number of balls in the ith box, and X¯ is the average number of balls in a box.
Your task is to find out the expected value of V.

Input

The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.
The input is terminated by n = m = 0.

Output

For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.

Sample Input

2 1
2 2
0 0

Sample Output
0/1
1/2

Hint

In the second sample, there are four possible outcomes, two outcomes with V = 0 and two outcomes with V = 1.

思路

网上看来的思路,其实题解一开始都没看懂。。
对于每个盒子,每个球落入其中的概率是p=1/m;
那么总共n个球p(x=k)=C(n,k)p^k(1-p)^(n-k),显然的二项分布;
二项分布数学期望E(x)=np(n是实验次数,p是每次试验球落入盒子的概率);
方差D(x)=np(1-p)
本题中D(x)=n/m*(1-1/m)=n*(m-1)/(m^2);
然后因为每个盒子是平等的,方差又是描述数据的混乱程度,所以多个均等的盒子的方差与单个盒子方差
是一样的

代码

#include <cstdio>
#include <iostream>
#define ll long long
using namespace std;

ll gcd(ll a, ll b) {
    if(a % b == 0)
        return b;
    return gcd(b, a % b);
}

int main() {
    ll n,m;
    while(scanf("%lld %lld", &n, &m), n || m) {
        ll fz = n * m - n;
        ll fm = m * m;
        ll _gcd = gcd(fz, fm);
        fz = fz / _gcd;
        fm = fm / _gcd;
        printf("%lld/%lld\n", fz, fm);
    }
    return 0;
}

hdu 5813

Problem Description

Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.
For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.
Your task is constructing such a city. Now it’s your showtime!

Input

The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.

Output

For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.

Sample Input

3
3
2 1 0
2
1 1
4
3 1 1 0

Sample Output

Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

思路

和官方题解一样,可以用贪心的思想来做。将顶点按能到达的点数从小到大排序,排好序之后每个点只能往前面的点连边. 因而如果存在一个排在第i位的点,要求到达的点数大于i-1,则不可行;否则就可以按照上述方法构造出图. 复杂度O(N^2).

代码

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

struct Node {
    int num;
    int id;
    bool operator < (const Node &x)const {
        return num < x.num;
    }
}a[1000 + 10];
vector<int>v[1000 + 10];

int main() {
    int T;
    scanf("%d", &T);
    for(int ncase = 1; ncase <= T; ncase++) {
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i].num);
            a[i].id = i;
            v[i].clear();
        }
        sort(a + 1, a + 1 + n);
        bool flag = true;
        for(int i = 1; i <= n; i++) {
            if(a[i].num >= i) {
                flag = false;
                break;
            }
            for(int j = 1; j <= a[i].num; j++) {
                v[a[i].id].push_back(a[j].id);
            }
        }
        printf("Case #%d: ", ncase);
        if(!flag) {
            printf("No\n");
            continue;
        }
        printf("Yes\n");
        int sum = 0;
        for(int i = 1; i <= n; i++) 
            sum += v[i].size();
        printf("%d\n", sum);
        for(int i = 1; i <= n; i++) {
            for(int j = 0; j < v[i].size(); j++)
                printf("%d %d\n", i, v[i][j]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/readlnh/article/details/52176065