E - QS Network ZOJ - 1586

E - QS Network

ZOJ - 1586


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0

Sample Output

370

题意:有n个点,每个点有个喜爱值,每两个点之间有边权值,那么两点之间的权值即为边权值加喜爱值,然后prim就行了。

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
int g[maxn][maxn],cost[maxn],d[maxn],vis[maxn],n;

int prim()
{
    memset(d,inf,sizeof(d));
    memset(vis,0,sizeof(vis));
    d[1] = 0;

    int sum = 0;
    while(1)
    {
        int v = -1;
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u] && (v == -1 || d[v] > d[u])) v = u;
        }
        if(v == -1) break;
        vis[v] = 1;
        sum += d[v];
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u]) d[u] = min(d[u],g[v][u]);
        }
    }
    return sum;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 1;i <= n;i++) scanf("%d",&cost[i]);
        for(int i = 1;i <= n;i++)
        {
            for(int j = 1;j <= n;j++)
            {
                scanf("%d",&g[i][j]);
                g[i][j] += cost[i];
                g[i][j] += cost[j];
            }
        }

        int ans = prim();
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Eric_chen_song_lin/article/details/82748297
qs