(poj)Catch That Cow

版权声明:本文为博主原创文章,转载时注明出处,附加链接即可。 https://blog.csdn.net/cswhit/article/details/52966394
Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 78708   Accepted: 24827

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <iostream>
#include <string.h>
#include <queue>
using namespace std;
struct node
{
    int data,step;
};
int vis[200000];
void func(int n,int k)
{
    struct node t,v;
    queue<struct node>S;
    t.step=0;
    t.data=n;
    vis[n]=1;
    S.push(t);
    while(!S.empty())
    {
        v=S.front();
        S.pop();
        if(v.data==k)
        {
            cout<<v.step<<endl;
            return ;
        }
        if(v.data>=1&&!vis[v.data-1])
        {
            t.data=v.data-1;
            t.step=v.step+1;
            S.push(t);
            vis[v.data-1]=1;
        }
        if(v.data<=k&&!vis[v.data+1])
        {
            t.data=v.data+1;
            t.step=v.step+1;
            S.push(t);
            vis[v.data+1]=1;
        }
        if(v.data<=k&&!vis[v.data*2])
        {
            t.data=v.data*2;
            t.step=v.step+1;
            S.push(t);
            vis[v.data*2]=1;
        }
    }
}
int main()
{
    int n,k;
    cin>>n>>k;
    memset(vis,0,sizeof(vis));
    func(n,k);
    return 0;
}


猜你喜欢

转载自blog.csdn.net/cswhit/article/details/52966394