Heavy Transportation Frogger恰恰相反

题目:

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4


题意:

给出一些街道的承重,现在,老板想将一些起重机从1号运输到n号,他想知道它能够运输的最大重量的起重机的重量;

分析:

最大的重量,一定是这条道路中的最小称重决定的,我们要做的就是找出最小称重最大的那个街道,这么一说就会发现跟之前写的

Frogger恰恰相反

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
using namespace std;
int e[2222][2222];
int book[2222],dis[2222];
int m,n;
int main()
{
    int t,t1,t2,t3,i,j,k,u,maxx,casee=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(e,0,sizeof(e));
        scanf("%d %d",&m,&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d %d %d",&t1,&t2,&t3);
            if(t3>0)
                e[t1][t2]=e[t2][t1]=t3;
        }


        memset(book,0,sizeof(book));
        memset(dis,0,sizeof(dis));
        for(i=1;i<=m;i++)
        {
            dis[i]=e[1][i];
        }


        for(i=1;i<=m;i++)
           {
                maxx=0;
                for(j=1;j<=m;j++)
                {
                    if(book[j]==0&&maxx<dis[j])
                    {
                        maxx=dis[j];
                        u=j;
                    }
                }
                book[u]=1;
                for(k=1;k<=m;k++)
                    dis[k]=max(dis[k],min(dis[u],e[u][k]));
           }
          printf("Scenario #%d:\n",++casee);
          printf("%d\n\n",dis[m]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/stdio_xuege/article/details/81053754