求n条直线交点个数

Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :) 
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point. 

Note: 
You can assume that two segments would not intersect at more than one point. 
 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
 

Output

For each case, print the number of intersections, and one line one case. 
 

Sample Input

 
    
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output

 
    
1 3


题目的意思是给定n条直线,每条直线由四个坐标确定

要求: 求给的n条直线的交点个数


#include<cstdio>
#include<cstring>
using namespace std;
struct Line {
    double x1,y1,x2,y2;
}a[105];
bool solve(Line a,Line b)
{
    if(((a.x1-b.x1)*(a.y2-b.y1)-(a.x2-b.x1)*(a.y1-b.y1))*((a.x1-b.x2)*(a.y2-b.y2)-(a.x2-b.x2)*(a.y1-b.y2))>0)return false;
    if(((b.x1-a.x1)*(b.y2-a.y1)-(b.x2-a.x1)*(b.y1-a.y1))*((b.x1-a.x2)*(b.y2-a.y2)-(b.x2-a.x2)*(b.y1-a.y2))>0)return false;
    return true;
}
int main(){
    int n;
    while(scanf("%d",&n),n){
        int sum = 0;
        for(int i = 0; i < n; i++)
            scanf("%lf %lf %lf %lf",&a[i].x1,&a[i].y1,&a[i].x2,&a[i].y2);

        for(int i = 0; i < n; i++){
            for(int j = i + 1; j < n; j++){
                if(solve(a[i],a[j]))
                    sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_24889575/article/details/46011205