1001 A+B Format (20 分)(这道题是甲级中最简单的题目,我会把所有的甲级算法全部学会,在这里立一个flag)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目很简单没有什么好说的。

代码: #include <iostream>
#include <bits/stdc++.h>
using namespace std;
int main()
{
    int a,b;
    int sum;
    stack<char>st;
    while(~scanf("%d%d",&a,&b))
    {
        sum = a+b;
        if(sum==0)
        {
            printf("0\n");
            continue;
        }
        else if(sum<0)
            printf("-");
        sum = abs(sum);
        int s = 0;
        while(1)
        {
            st.push(sum%10+'0');
            sum = sum /10;
            if(sum==0)
                break;
            s++;
            if(s%3==0)
                st.push(',');
        }
        while(!st.empty())
        {
            printf("%c",st.top());
            st.pop();
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ACMerdsb/article/details/83478168
今日推荐